Filter set filed data source

the problem now arises in the lookup … how can I filter the field by username?

@Maxr167 your error is a PHP syntax error. you need to look at the structure of the content there, before adding yours.
Replace this
with this

When your query is generated by Radsystems Studio, it looks like this
$sqltext = "SELECT DISTINCT chiamata_cliente AS value,chiamata_cliente AS label FROM chiamata ORDER BY chiamata_cliente ASC WHERE chiamata_assegnata LIKE "%".auth()->user()->username."%" ";
which is synthetically wrong.

Once you do what I stated above it will be generated this way
$sqltext = "SELECT DISTINCT chiamata_cliente AS value,chiamata_cliente AS label FROM chiamata WHERE chiamata_assegnata LIKE '%".auth()->user()->username."%' ORDER BY chiamata_cliente ASC";
which is synthetically correct.

Take note of the number of double quotes("), the first and the last double quotes are added by Radstystems Studio, and when you are adding your query you should but that in mind.


Hi Willvin, thanks for your help. I replaced the filter as you said but it doesn’t work.

Hi, @Maxr167 please PM me your Teamviewer or Anydesk details.


when you want you can connect; I don’t know if I’ll be there for you, go ahead … for the user program max password max

412 996 409


After connecting with @Maxr167, the issue was that

was not accessible from the Datasource, which is a bug. And it has been reported to the dev.

This will be address in the next release coming in few days.

Here, too, the problem remains

@Maxr167 please note that this issue has been fixed with the new 3.5 update. Either you create a new project or you delete the old generated project folder and republish the project, thanks.

already done; i don’t see the problem solved

@Maxr167 please make sure you have configured Authentication and the field you are trying to compare the username actually contains a user name Thanks.

already done; I don’t see the problem solved.

please send me your AnyDesk id.

excuse me but we have to feel later

when you want you can connect

412 996 409 psw 12345678 (teamviewer)

hi, if TW is active you can connect there are no problems …

@Maxr167 tried connecting several times but the password you provided was wrong.

sorry maybe the password was wrong…ok try now

@Maxr167 still wrong.


new password 3jng72

alternatively anydesk 928 705 991