Configuring the Roles and Permission in Radsystems Studio (PHPRad Classic)

This tutorial teaches you how to properly configure Roles and Permission in your Radsystems Studio (PHPRad Classic) Project. And also provide clarity to all tables created by Radsystems Studio, due to the configuration of Roles and Permission.

Please work in a most efficient and intuitive way to manage all this process, is VERY confusing. I think you can automate mostly of these tasks, so Admin can be auto created with a default password, and starting to this point, admin can create/configure any other accounts including his/herself. Furthermore, it would be ideal have a graphic interface to manage permissions and roles.

1 Like

I used the video and tried the example. Its seems a terrible mess. I guess it was not tested before uploading. I think i will stay off version 4.0 for a while. It is generally known that and version X.0 is usually buggy. We have a security standard that requires us to stay away from Version X.0 up to X.0.5.

I have tried as per this tutorial in phpRAD Vue but no permission is populated in table. Please help me.

Thanks

Hi Willvin, do you have tutorial about setting audit trail? because I have try it, but didn’t work. Thankyou.I using PHPRad version 5.0

No tutorial. what error are you getting?

I also tried and failed.
The system is not creating the audits table

Please send me a PM with your TeamViewer or Anydesk details let me take a look.

1 Like

I have availability now

Send me a PM with your connection details.

Hi Willvin,

Please see below video and help me to fix this issue.

https://www.youtube.com/watch?v=y-I6znXjKq4

@usmraf786 please set your password field in your database users table to Varchar(255) And upload a landscape image if you want it to look nice.

Please see below snapshot, Already password field is Varchar(255)

@usmraf786 that is usually the cause of the error you are having. You should try backing up and deleting the generated project folder, then republish your app. if the error still exists, there is nothing more I can do for you without debugging the app to find the issue, as none of my projects created with phprad classic has that error.

@willvin please upload a .sql example of the roles dbs, so i can made it manually
:pray:

Someone have the version 4.0 to download? I did exactly as shown in the video and even then the tables were empty.
probably the 4.0 version he uses in this video should be working.

What specific error are you encountering please provide screenshots and explanations to help understand.

image
image

RadSystems create the tables, but not populate them. I’m runing version 5.1.4 (latest)

please send me your TeamViewer details or Anydesk ID