Master Detail error

I am trying to build a simple test app. At this point its names and addresses. I just want to learn how to do simple things using it like setting up master detail relationships, etc.

I have the process kind of working, I doing a PyRad/SQLite project, if that matters. I can select a name and it will show addresses I have created and manually linked to the name record. That is done using a third party db editor. I have not been able to get it to link like it should. If I open the view table of related address for the name it shows those items However, the Add New Address does not work. It just times out and the program stops working.

I tried various things to get this to function without success. I simply cannot add a new record. Even if I bypass the names table and go directly to the Address table it will not work. Add New Address is not functioning.

If I delete the Master Detail relationship then at least on the Address table I can enter new data but this is not what I want to happen.

I have attached an image of the page with the browser error messages. It appears to be looking for something that does not exist.

Finally I have tried all the usual stuff opening/closing the app, opening closing the ide, deleting and rebuilding tables, restarting the pc, etc. All without success. I dont know if this is a bug or an error on my part. The videos on PHPRad indicate I am doing things correctly.

@jkwrpc the error in the image you provided does not relate to the master details configuration, but rather the favicons. Please give a clearer picture of the idea you are trying to archive and also provide a screenshot of your master details configuration.

As I described, this is a simple PyRad/SqLite app. I am just trying to learn RADSysems workflow. I have names and want to relate a number addresses to the name. Its the one to many. I can go into the db address table and manually set the relation. That is not what I want. I want to be able to select the Name, view the record and add and new address to it.

It kind of works where I have manually set data in the related fields. That is I can view the related records. I cannot add records.

However, it fails when I go to the Name record, view the related addresses then select Add New Address it times out. If I try to just the use the Address table and try to Add New Address it fails. If I delete the relation I can Add New Address from the Address table/page.

Here are a couple of images one is running the app and the timeout error, the other is the Master Detail set up…

Any suggestions are appreciated.

I can only embed one items in a post so here is the second image.

@jkwrpc first of all what version of Radsystems Studio are you running? Secondly, I don’t seem to encounter the issue you are having. I tried the one-to-many relation from my end and it worked fine. When I click on the master record button, the modal for the details record was shown with the required data. when I clicked on the add button, I was taken to the details add page.

Note: To add multiple files to a post on this forum, just press and hold the Ctrl button while selecting the images.

I am using v3.4. I was surprised by the problem. I have been developing for nearly 35 years so I get the concept, but I must be missing something.

Here is a link to a video showing an error happening. I am not so good with video my apologies. This a complete new start and build of the PyRad/SQLite app. Same concept… name with many addresses.

Ashampoo® Web Upload

Some closer to a solution. When I add a name for the fist time I can add addresses. When I go back to that name I can add another address, but it does not link to the name. In my case the link should be = address.name_id. It does not set the address.name_id to the value of the Because of that relationship is not being set.

@jkwrpc from the error in your project it means your python API is not running.

Thanks, I also found the application did not like how I had set the db to handle nulls.

So it works to a point. For some reason when I select a name and try to enter another address for it using the related screen it does not set the relationship like it does when I enter a new name and addresses.

It leaves the linking field (address.name_id) empty when it should contain the value of the

Am I missing a setting or is there a code snippet I need to add?

Tengo el mismo problema…