PHPRAD CLASSIC NOT COMPATIBLE WITH PHP 8.1 and laravel 8

in my tests using laragon, i upgraded via composer to laravel 8 with php 8.1 it didn’t work, i assume the PHPRAD CLASSIC development team MUST UPDATE the package and make the version more stable with php 8.1 and laravel 8.

in short version 5 is only compatible with PHP 7.4

@snarthost this is not a bug, the version of laravel Radsystems used for its project generation is Laravel 7, and the PHP version supported by Laravel 7, applies to project generated by Radsystems Studio. If you want to use Laravel 8 before radsystems supports it you will have to do the migration yourself, thanks.

I give up. Decided to stick to the old Classic Version. We have developed our own version of Vuejs,Quasar and Codeigniter package and works fantastic.

Can you guide how i can migrate?

After generating your project, you will have to manually do the changes to the generated project. here is a link on the steps to take Upgrade Guide - Laravel - The PHP Framework For Web Artisans. Do the following listed there and when you encounter an error consult that link, search on google or ask here and anyone with solutions can help you out.

Thanks,
Can you tell me What web hosting requirements to host PHPRad System Classic app on web hosting.

A vps, dedicated server, or a shared hosting you have access to command line or terminal access.

Upgrade to Laravel8, php 7.3+, Quasar 1.18 [email protected]