Nodejs-App dosn't start

I get following message from the console:

[email protected] start
./node_modules/.bin/nodemon app.js --delay 2 -e js

Der Befehl “.” ist entweder falsch geschrieben oder
konnte nicht gefunden werden.

C:\USERS\PERBA\ONEDRIVE\DOKUMENTE\RADSYSTEMS\NODERAD PROJECTS\PLOTS\NODEJS-EXPRESS-API>

What can be wrong? It is a simple app, only 2 tabeles in it.

@Perby share screenshot of the entire error

@Perby please refer to the steps given in this topic Spa platform configuration problem - Questions / NodeRad Vue - Radsystems Forum.

Now Im getting;
TypeError: Class extends value undefined is not a constructor or null
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\agent.js:114:44)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\index.js:5:33)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\make-fetch-happen\lib\agent.js:161:25)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
TypeError: Class extends value undefined is not a constructor or null
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\agent.js:114:44)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\index.js:5:33)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\make-fetch-happen\lib\agent.js:161:25)
at Module._compile (node:internal/modules/cjs/loader:1101:14)

and

Dev mode… spa
Pkg quasar… v1.17.5
Pkg @quasar/app… v3.2.6
Pkg webpack… v5
Debugging… enabled

Configured browser support (>= 89.34% of global marketshare):
· Chrome for Android >= 97
· Firefox for Android >= 95
· Android >= 97
· Chrome >= 88
· Edge >= 94
· Firefox >= 87
· iOS >= 12.0-12.1
· Opera >= 78
· Safari >= 13

App • Running “@quasar/qcalendar” Quasar App Extension…

App • :warning: Extension(@quasar/qcalendar): is not compatible with @quasar/app v3.2.6. Required version: ^1.3.0 || ^2.0.0
Whats wrong?

What you are using was not generated by the Radsystems Studio App, you have modified the library used. From the error it shows you are using @quasar/app v3.2.6 and what Radsystems Studio uses is @quasar/app v2.0.0. Please delete the project folder and regenerate the app.

OK, regenerated the app, now getting:

TypeError: Class extends value undefined is not a constructor or null
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\agent.js:114:44)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\index.js:5:33)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\make-fetch-happen\lib\agent.js:161:25)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
TypeError: Class extends value undefined is not a constructor or null
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\agent.js:114:44)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\index.js:5:33)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\make-fetch-happen\lib\agent.js:161:25)
at Module._compile (node:internal/modules/cjs/loader:1101:14)

and

Dev mode… spa
Pkg quasar… v1.14.7
Pkg @quasar/app… v2.1.11
Debugging… enabled

Browserslist: caniuse-lite is outdated. Please run:
npx [email protected] --update-db

Why you should do it regularly:

Configured browser support (at least 87.89% of global marketshare):
· Chrome for Android >= 87
· Firefox for Android >= 83
· Android >= 81
· Chrome >= 77
· Edge >= 84
· Firefox >= 75
· iOS >= 10.3
· Opera >= 68
· Safari >= 11

App · Reading quasar.conf.js
App · Checking listening address availability (0.0.0.0:8050)…
App · Transpiling JS (Babel active)
node:fs:585
handleErrorFromBinding(ctx);
^

[ Error: ENOENT: no such file or directory, open ‘C:\XAMPP\HTDOCS\NODEPLOTS\NODEPLOTS\FRONTEND\src\index.template.html’

  • node:fs:585 Object.openSync
    node:fs:585:3

  • node:fs:453 Object.readFileSync
    node:fs:453:35

  • app-files-validations.js:13 module.exports
    [FRONTEND]/[@quasar]/app/lib/helpers/app-files-validations.js:13:16

  • quasar-conf-file.js:543 QuasarConfFile.compile
    [FRONTEND]/[@quasar]/app/lib/quasar-conf-file.js:543:5

  • task_queues:96 processTicksAndRejections
    node:internal/process/task_queues:96:5

  • quasar-dev:222 async goLive
    [FRONTEND]/[@quasar]/app/bin/quasar-dev:222:3

] {
errno: -4058,
syscall: ‘open’,
code: ‘ENOENT’,
path: ‘C:\XAMPP\HTDOCS\NODEPLOTS\NODEPLOTS\FRONTEND\src\index.template.html’

Before regenerating it you need to close the Radsystems Studio App and reopen the project, then publish it. Make sure to delete the folder again before you do this.

Didnt helped. Still getting:

TypeError: Class extends value undefined is not a constructor or null
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\agent.js:114:44)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\index.js:5:33)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\make-fetch-happen\lib\agent.js:161:25)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
TypeError: Class extends value undefined is not a constructor or null
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\agent.js:114:44)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\index.js:5:33)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\make-fetch-happen\lib\agent.js:161:25)
at Module._compile (node:internal/modules/cjs/loader:1101:14)

Could it be, that I use the wrong Nodejs-Version? I use 16.3.2 at the moment.

Getting:

TypeError: Class extends value undefined is not a constructor or null
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\agent.js:114:44)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\index.js:5:33)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\make-fetch-happen\lib\agent.js:161:25)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
TypeError: Class extends value undefined is not a constructor or null
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\agent.js:114:44)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\socks-proxy-agent\dist\index.js:5:33)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (C:\nodejs\node_modules\npm\node_modules\make-fetch-happen\lib\agent.js:161:25)
at Module._compile (node:internal/modules/cjs/loader:1101:14)

But the App runs!

@Perby has everything to do with your node js version if you are using version 16 that will always give you errors.you need to roll back to 14…
As for quasar that shouldn’t be complicated.you can message me directly I will connect we look into the error together

Installed nodejs 14. Now getting this error:

[email protected] start C:\XAMPP\HTDOCS\PLOTSNODE\PLOTSNODE\NODEJS-EXPRESS-API
nodemon app.js --delay 2 -e js

[nodemon] 2.0.13
[nodemon] to restart at any time, enter rs
[nodemon] watching path(s): .
[nodemon] watching extensions: js
[nodemon] starting node app.js
C:\XAMPP\HTDOCS\PLOTSNODE\PLOTSNODE\NODEJS-EXPRESS-API\models\index.js:31
const Users = require("./users").init(sequelize, Sequelize);
^

SyntaxError: Identifier ‘Users’ has already been declared
at wrapSafe (internal/modules/cjs/loader.js:1001:16)
at Module._compile (internal/modules/cjs/loader.js:1049:27)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1114:10)
at Module.load (internal/modules/cjs/loader.js:950:32)
at Function.Module._load (internal/modules/cjs/loader.js:790:12)
at Module.require (internal/modules/cjs/loader.js:974:19)
at require (internal/modules/cjs/helpers.js:93:18)
at Object. (C:\XAMPP\HTDOCS\PLOTSNODE\PLOTSNODE\NODEJS-EXPRESS-API\controllers\components_data.js:35:16)
at Module._compile (internal/modules/cjs/loader.js:1085:14)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1114:10)
[nodemon] app crashed - waiting for file changes before starting…

Are you sure its 14.15.2??? @Perby

It is 14.18.

Kind regards

Installed 14.15.2. This changes nothing.

Send me your zoom details to my email we can connect see if we can fix it